Resultat 1 till 22 av 22

Ämne: Felsöka mutable-bygge, hur gör man?

  1. #1
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior

    Felsöka mutable-bygge, hur gör man?

    Byggde en Shades som min första smd och tänkte att det här går aldrig, lödningarna var inte vackra osv. Men slår på strömmen och.. wow! Ingen rök, ingen eld.

    Kanal 1 och 2 verkar bete sig korrekt, när jag mäter får jag 2,5v på output på 1, 5v på 2 (summerat) utan någon input. Och ljud passerar genom som det ska.

    Leds på 1 och 2 verkar ok, de skiftar som de ska.

    Nu till kanal 3. Den står alltid och lyser rött, och mäter jag likadant som de tidigare får jag ett minus före 7, nånting eller 10 nånting. Om jag skiftar kablar till omvänt på multimeter så blir det plus istället men samma värden.

    Det verkar som att någonstans är något felvänt, och kanske har jag bryggat något.

    Har ju en schematic så jag kan följa den men som noob vet jag inte riktigt vad jag gör. Kan man highlighta grejer i eagle för enklare felsökning, eller vad hade ni gjort?

    Är halvnöjd ändå, 2/3 funkar ju faktiskt och det var mer än väntat.

    Finns det någonstans man kan ställa dessa frågor annars, vid sidan av här och muffs?

  2. #2
    jgb
    jgb är inte uppkopplad
    jgbs avatar
    Fjomp
    Fungerar kanal 3 när du vrider på ratten?

    I och med att det är SMD så skulle jag ta fram förstoringsglaset och dubbelkolla att det är rätt (åtminstone liknande) komponenter på rätt plats, samt se över lödningarna så att du inte har några bryggor.

  3. #3
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Citat Ursprungligen postat av jgb Visa inlägg
    This quote is hidden because you are ignoring this member.
    Fungerar kanal 3 när du vrider på ratten?

    I och med att det är SMD så skulle jag ta fram förstoringsglaset och dubbelkolla att det är rätt (åtminstone liknande) komponenter på rätt plats, samt se över lödningarna så att du inte har några bryggor.
    Nej, inte märkbart. Tror jag. Ska kolla igen.

  4. #4
    ZX81
    ZX81 är inte uppkopplad
    ZX81s avatar
    Senior
    I Eagle kan du skriva "ratsnest" i kommandoraden längst upp så får du se jordplanet. Det gör det hela lite tydligare tycker jag. Följ sedan signalen från in 3-jacket och vidare genom att klicka på det.

    Klicka på bilden för en större version. 

Namn:	shades.png 
Visningar:	4 
Storlek:	61,8 KB 
Id:	86606

    Här verkar den gå genom en 100k-resistor -> pot -> op-förstärkaren LME49720.

    Jag kan rekommendera facebookgruppen Pusherman's Eurorack DIY Noobs! Väldigt bra resurs.

  5. #5
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Citat Ursprungligen postat av ZX81 Visa inlägg
    This quote is hidden because you are ignoring this member.
    I Eagle kan du skriva "ratsnest" i kommandoraden längst upp så får du se jordplanet. Det gör det hela lite tydligare tycker jag. Följ sedan signalen från in 3-jacket och vidare genom att klicka på det.

    Klicka på bilden för en större version. 

Namn:	shades.png 
Visningar:	4 
Storlek:	61,8 KB 
Id:	86606

    Här verkar den gå genom en 100k-resistor -> pot -> op-förstärkaren LME49720.

    Jag kan rekommendera facebookgruppen Pusherman's Eurorack DIY Noobs! Väldigt bra resurs.
    Underbart Herman, tack som f*n! Det här kommer underlätta väldigt mycket!

  6. #6
    ZX81
    ZX81 är inte uppkopplad
    ZX81s avatar
    Senior
    De nada! Lycka till med felsökningen!

  7. #7
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Är på gång nu, kör uteslutningsmetoden och följer alla signalvägar en i taget. Gått igenom tio hittills utan fel, bara att köra på. Rätt kul på ett sätt , man lär sig ju iaf..

  8. #8
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Nu har jag gått igenom alla signals, rubbet! Och helt utan fel, alla signaler går fram som det är tänkt.
    Något annat jag kan prova?
    Ska höra mig för på pusherman också, men tänkte det kanske fanns något mer tips ni kunde ge?Klicka på bilden för en större version. 

Namn:	signals.jpg 
Visningar:	2 
Storlek:	41,7 KB 
Id:	86625

    Såg en sak nu, som inte borde ha betydelse, men de tre switcharna där man väljer mellan att de ska fungera som mixer och något annat, de är väl knappast beroende av riktning? I översta och nedersta läget står det "on" på ena sidan och på andra sidan står det någon annan text. Lär väl inte spela någon roll? Eftersom 1 och 2 fungerar som de ska och där är de riktade tvärt emot varandra..

    De två första outputs får fortfarande rätt värden, 5 volt medan kanal tre får -7.8 volt-
    Senast redigerat av defalut den 2019-03-17 klockan 12:02.

  9. #9
    jgb
    jgb är inte uppkopplad
    jgbs avatar
    Fjomp
    Men var kommer felet in då? Hur långt är det rätt, när dyker felet upp?

  10. #10
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Citat Ursprungligen postat av jgb Visa inlägg
    This quote is hidden because you are ignoring this member.
    Men var kommer felet in då? Hur långt är det rätt, när dyker felet upp?
    Felet är där hela tiden, 1och 2 funkar perfekt, 3 och kretsen fungerar inte alls. Eftersom alla signaler är felfria när jag kollat vet jag inte riktigt vad jag ska göra. Kanske börja mäta värden och jämföra? Eftersom det är minus plötsligt på trean kan det vara någon lödbrygga som kortsluter? Kanske ska kolla schemat för trean och se hur det verkar. Har ju två fungerande att jämföra med..

  11. #11
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Får väl backa från output 3 där jag mäter upp felet helt enkelt..

  12. #12
    jgb
    jgb är inte uppkopplad
    jgbs avatar
    Fjomp
    Mmm, jag tror det är en bra metod. In med samma input i en korrekt och den felaktiga, mät signalen hela vägen (om du har möjlighet) och se var det skiljer sig.

  13. #13
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Citat Ursprungligen postat av jgb Visa inlägg
    This quote is hidden because you are ignoring this member.
    Mmm, jag tror det är en bra metod. In med samma input i en korrekt och den felaktiga, mät signalen hela vägen (om du har möjlighet) och se var det skiljer sig.
    Yes! Jag har en plan. Fasen vad man lär sig mycket, börjar bli kul det här ju... Önskar bara att jag inte behövde passa ungen hela dagarna.

  14. #14
    machinepop
    machinepop är inte uppkopplad
    machinepops avatar
    Administrator
    Citat Ursprungligen postat av defalut Visa inlägg
    This quote is hidden because you are ignoring this member.
    Yes! Jag har en plan. Fasen vad man lär sig mycket, börjar bli kul det här ju... Önskar bara att jag inte behövde passa ungen hela dagarna.
    Elektronik är kul, men... om det där var på allvar så hoppas jag du kan tänka om.

    /i all välmening

  15. #15
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Citat Ursprungligen postat av machinepop Visa inlägg
    This quote is hidden because you are ignoring this member.
    Elektronik är kul, men... om det där var på allvar så hoppas jag du kan tänka om.

    /i all välmening
    Menar alltså att jag önskar jag hade mer tid! Älskar henne över allt annat och det tog oss tio år av sorg och depressioner tills vi fick henne så..

  16. #16
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Citat Ursprungligen postat av jgb Visa inlägg
    This quote is hidden because you are ignoring this member.
    Mmm, jag tror det är en bra metod. In med samma input i en korrekt och den felaktiga, mät signalen hela vägen (om du har möjlighet) och se var det skiljer sig.
    Hmm, en fundering bara.. Är lite nojig men som tur är har jag ett extra uzeus jag kan ha på bordet och leverera ström för teständamål, och sedan behöver jag bara en modul som skickar in två identiska signaler.. right?

  17. #17
    iopop
    iopop är inte uppkopplad

    Börjar bli varm i kläderna
    Du borde väl kunna koppla utgång 1 till ingång 2 och 3?
    Från https://mutable-instruments.net/modules/shades/
    "Unconnected inputs are normalized to an internal precision voltage reference, which can produce either a +5V or +10V constant voltage."

    Jag har ingen erfarenhet av modulen men av ren nyfikenhet kollade jag schemat. Den är rätt enkel så det borde vara en komponent med felaktigt värde eller en lödning som kortsluter eller är glömt. Så många gånger jag felsökt för att tillslut upptäcka att jag glömt löda in komponenten.

    Ta ett screenshot på schemat, rita sen direkt på bilden och följd signalen. Du hittar det tillslut och lär dig massor.

  18. #18
    jgb
    jgb är inte uppkopplad
    jgbs avatar
    Fjomp
    Citat Ursprungligen postat av defalut Visa inlägg
    This quote is hidden because you are ignoring this member.
    Hmm, en fundering bara.. Är lite nojig men som tur är har jag ett extra uzeus jag kan ha på bordet och leverera ström för teständamål, och sedan behöver jag bara en modul som skickar in två identiska signaler.. right?
    Exakt.

  19. #19
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Citat Ursprungligen postat av iopop Visa inlägg
    This quote is hidden because you are ignoring this member.
    Du borde väl kunna koppla utgång 1 till ingång 2 och 3?
    Från https://mutable-instruments.net/modules/shades/
    "Unconnected inputs are normalized to an internal precision voltage reference, which can produce either a +5V or +10V constant voltage."

    Jag har ingen erfarenhet av modulen men av ren nyfikenhet kollade jag schemat. Den är rätt enkel så det borde vara en komponent med felaktigt värde eller en lödning som kortsluter eller är glömt. Så många gånger jag felsökt för att tillslut upptäcka att jag glömt löda in komponenten.

    Ta ett screenshot på schemat, rita sen direkt på bilden och följd signalen. Du hittar det tillslut och lär dig massor.
    Ja, det låter enkelt och smidigt, så gör jag. Tack för tipsen!

  20. #20
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Problem löst!
    Det var ett ben på IC4 som inte riktigt hade kontakt med plattan. Så enkelt när man vet det. Nu funkar allt finemang! Tack för alla goda råd gott folk!

  21. #21
    jgb
    jgb är inte uppkopplad
    jgbs avatar
    Fjomp
    Gott att höra! Nu har du lärt dig alldeles för mycket om felsökning, läsa scheman och följa signalvägar.

  22. #22
    defalut
    defalut är inte uppkopplad
    defaluts avatar
    Senior
    Citat Ursprungligen postat av jgb Visa inlägg
    This quote is hidden because you are ignoring this member.
    Gott att höra! Nu har du lärt dig alldeles för mycket om felsökning, läsa scheman och följa signalvägar.
    Har lärt mig lite iaf, men användbara grejer! Och har fått blodad tand på fler byggen nu; tre st avklarade inklusive mitt första smd så nu har jag branches, ripples och veils att ta tag i. Eller så säljer jag de och bygger något annat.

Liknande ämnen

  1. Hur gör man?
    Av Cyberwelt i forum Mixning & mastring
    Svar: 2
    Senaste inlägg: 2013-05-28, 09:07
  2. Bygge av en simpel CV-gate klaviatur, hur gör man ?
    Av codemuzak i forum DIY - bygg & reparation
    Svar: 8
    Senaste inlägg: 2010-12-05, 22:22
  3. Svar: 15
    Senaste inlägg: 2005-08-23, 02:09

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •